re = /"[^"\\]*(?:\\.[^"\\]*)*"|[^,]+|(?<=^|,)(?=$|,)/
str = ', first,last,,44433"ll\\""34444,"k\\.",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end