#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^:(\w+):\s+((?:\s*(?!:)[^\s]+)+)"
Local $sString = ":6585d0f0ba88767ac3b590f719596d864d73e9c1:" & @CRLF & _
"" & @CRLF & _
"harmonicbalance/src/harmonicbalance/HarmonicBalanceFlowModel.cpp" & @CRLF & _
"harmonicbalance/src/harmonicbalance/HbFlutterModel.cpp" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
":8302994b565553c83a048b8905ae597349d99627:" & @CRLF & _
"" & @CRLF & _
"emp/src/emp/PhasePairSingleParticleReynoldsNumber.h" & @CRLF & _
"emp/src/emp/TomiyamaDragCoefficientMethod.cpp" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
":9da194f17ec08bb20ad1be8df68b78ca137ab18a:" & @CRLF & _
"" & @CRLF & _
"combustion/src/combustion/ReactingSpeciesTransportBasedModel.cpp" & @CRLF & _
"combustion/src/complexchemistry/TurbulentFlameClosure.cpp" & @CRLF & _
":6a59f0be1e347a65e525e58742bb304639ea9bc4:" & @CRLF & _
"" & @CRLF & _
"meshing/src/meshing/SurfaceMeshManipulation.cpp" & @CRLF & _
"physics/src/discretization/FvIndirectRegionInterfaceManager.cpp" & @CRLF & _
"physics/src/discretization/FvIndirectRegionInterfaceManager.h" & @CRLF & _
"physics/src/discretization/FvRepresentation.cpp" & @CRLF & _
"physics/src/discretization/FvRepresentation.h" & @CRLF & _
":64b7f6d36b11b6cd94c20cad53463b7deef8c85a:" & @CRLF & _
"" & @CRLF & _
"resourceclient/src/resourceclient/ResourcePool.cpp" & @CRLF & _
"resourceclient/src/resourceclient/ResourcePool.h" & @CRLF & _
"resourceclient/src/resourceclient/RestClient.cpp" & @CRLF & _
"resourceclient/src/resourceclient/RestClient.h" & @CRLF & _
"resourceclient/src/resourceclient/test/ResourcePoolTest.cpp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")