# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^:(\w+):\s+((?:\s*(?!:)[^\s]+)+)"
test_str = (":6585d0f0ba88767ac3b590f719596d864d73e9c1:\n\n"
"harmonicbalance/src/harmonicbalance/HarmonicBalanceFlowModel.cpp\n"
"harmonicbalance/src/harmonicbalance/HbFlutterModel.cpp\n\n\n\n"
":8302994b565553c83a048b8905ae597349d99627:\n\n"
"emp/src/emp/PhasePairSingleParticleReynoldsNumber.h\n"
"emp/src/emp/TomiyamaDragCoefficientMethod.cpp\n\n\n"
":9da194f17ec08bb20ad1be8df68b78ca137ab18a:\n\n"
"combustion/src/combustion/ReactingSpeciesTransportBasedModel.cpp\n"
"combustion/src/complexchemistry/TurbulentFlameClosure.cpp\n"
":6a59f0be1e347a65e525e58742bb304639ea9bc4:\n\n"
"meshing/src/meshing/SurfaceMeshManipulation.cpp\n"
"physics/src/discretization/FvIndirectRegionInterfaceManager.cpp\n"
"physics/src/discretization/FvIndirectRegionInterfaceManager.h\n"
"physics/src/discretization/FvRepresentation.cpp\n"
"physics/src/discretization/FvRepresentation.h\n"
":64b7f6d36b11b6cd94c20cad53463b7deef8c85a:\n\n"
"resourceclient/src/resourceclient/ResourcePool.cpp\n"
"resourceclient/src/resourceclient/ResourcePool.h\n"
"resourceclient/src/resourceclient/RestClient.cpp\n"
"resourceclient/src/resourceclient/RestClient.h\n"
"resourceclient/src/resourceclient/test/ResourcePoolTest.cpp")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.