re = /(\\)(?=\")/m
str = '"Hello\\na = a.split(\\"\\n\\")'
subst = '\\\\\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result