#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?us)\b([Ѐ-ЯҐ-ҲFӮҶӢ]+)(.+?)(?:\n(?=[Ѐ-ЯҐ-ҲFӮҶӢ])|$)"
Local $sString = "ОБАНДОМ آباندام маљ. обпайкар, нозукан- дом, латифбадан." & @CRLF & _
"FБАФКАН آبافكن муњаррики обафкан, даст- гоњи обпошї." & @CRLF & _
"БАНЉИР انجير آب обе, ки дар он анљири ќоќ" & @CRLF & _
"ва хушкро мељӯшонанд ва он хусусияти" & @CRLF & _
"табобатї дорад." & @CRLF & _
"ӮББАДАЛ بدل آب муовизаи об, табдили об." & @CRLF & _
"ТББАНД بند آب 1. он ки дар пеши об банд ё" & @CRLF & _
"дарѓот месозад. 2. банд, дарѓот." & @CRLF & _
"ОББАР بر آب 1. он ки об мебарад, обкаш, маш- коб. 2. маљ. маъшуќ, ки тавассути њуснаш" & @CRLF & _
"обрўи ошиќи худро зери хавфи коҳиш" & @CRLF & _
"мегузорад. 3. тех. облўла, лўлаи обрасонї, ќубури обгузар." & @CRLF & _
"ЗББАРДОР آببردار 1. обро ба худ гиранда, он" & @CRLF & _
"чи зиёд об талаб мекунад, обталаб; биринљи" & @CRLF & _
"оббардор. 2. ниг. обчинак." & @CRLF & _
"ҚББАРДОРЇ آببرداري 1. обкашї, машкобї. 2." & @CRLF & _
"об бардоштани чизе (мас., биринљ)." & @CRLF & _
"ҶББАРДОШТА برداشته آب рахнае, ки бо фишор" & @CRLF & _
"ё љараёни об ба амал омадааст, оббурда, об- шуста (мас., дар банди об ё замин)." & @CRLF & _
"ӢББАРО برا آب љои баромади об, љое, ки об аз" & @CRLF & _
"он љорї мешавад." & @CRLF & _
"ЪББАЊО بها آب кит. музди об, пули об." & @CRLF & _
"ӢББО اآب нидо, лањљ. изњори тааљљуб ва афсўс." & @CRLF & _
"РББОЗ باز آب шиновар, ѓаввос, обдон, оббур." & @CRLF & _
"ОББОЗИДОРЇ بازيداري آبоббозї доштан" & @CRLF & _
"(мас., кўдакро, беморро ва ѓ.)" & @CRLF & _
"ОББОЗЇ آببازي шиноварї, оббурї; оббозї кар- дан ба об даромадан ва шустушў кардан, шино кардан." & @CRLF & _
"СББУР بر آب 1. ниг. оббоз. 2. бахши пеши поя- њои пулу купрукњо муќобили љараёни об, ки" & @CRLF & _
"нўгтез буда, мављњои обро таќсим карда, фишори обро бар сутуни пояњо суст мекунад." & @CRLF & _
"ОББУРДА برده آب 1. љои рахна карда хокро" & @CRLF & _
"шуста бурдаи об, љои обшустаи дарѓот. 2." & @CRLF & _
"љар, љарї, сой." & @CRLF & _
"ҲББУРЇ بري آب обро бурида гузаштан, шиноварї." & @CRLF & _
"ОБВАРЗ ورز آب обдон, оббоз, шиновар." & @CRLF & _
"ДБВАРЗЇ ورزي آب оббозї, шиноварї." & @CRLF & _
"УБГАЗ آبگز осебдида ва зарардида бар асари" & @CRLF & _
"муддати зиёд зери об мондан." & @CRLF & _
"ОБГАРДИШ گردش آب 1. хамгашт (-и дарё). 2." & @CRLF & _
"гирдоб. 3. таѓйири мусбат ва ё манфии таб- дили иќлим ба саломатї; нотобї бар асари" & @CRLF & _
"табдили иќлим. 4. кит. тезрафтор, хушраф- тор."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")