use strict;
my $str = 'ОБАНДОМ آباندام маљ. обпайкар, нозукан- дом, латифбадан.
FБАФКАН آبافكن муњаррики обафкан, даст- гоњи обпошї.
БАНЉИР انجير آب обе, ки дар он анљири ќоќ
ва хушкро мељӯшонанд ва он хусусияти
табобатї дорад.
ӮББАДАЛ بدل آب муовизаи об, табдили об.
ТББАНД بند آب 1. он ки дар пеши об банд ё
дарѓот месозад. 2. банд, дарѓот.
ОББАР بر آب 1. он ки об мебарад, обкаш, маш- коб. 2. маљ. маъшуќ, ки тавассути њуснаш
обрўи ошиќи худро зери хавфи коҳиш
мегузорад. 3. тех. облўла, лўлаи обрасонї, ќубури обгузар.
ЗББАРДОР آببردار 1. обро ба худ гиранда, он
чи зиёд об талаб мекунад, обталаб; биринљи
оббардор. 2. ниг. обчинак.
ҚББАРДОРЇ آببرداري 1. обкашї, машкобї. 2.
об бардоштани чизе (мас., биринљ).
ҶББАРДОШТА برداشته آب рахнае, ки бо фишор
ё љараёни об ба амал омадааст, оббурда, об- шуста (мас., дар банди об ё замин).
ӢББАРО برا آب љои баромади об, љое, ки об аз
он љорї мешавад.
ЪББАЊО بها آب кит. музди об, пули об.
ӢББО اآب нидо, лањљ. изњори тааљљуб ва афсўс.
РББОЗ باز آب шиновар, ѓаввос, обдон, оббур.
ОББОЗИДОРЇ بازيداري آبоббозї доштан
(мас., кўдакро, беморро ва ѓ.)
ОББОЗЇ آببازي шиноварї, оббурї; оббозї кар- дан ба об даромадан ва шустушў кардан, шино кардан.
СББУР بر آب 1. ниг. оббоз. 2. бахши пеши поя- њои пулу купрукњо муќобили љараёни об, ки
нўгтез буда, мављњои обро таќсим карда, фишори обро бар сутуни пояњо суст мекунад.
ОББУРДА برده آب 1. љои рахна карда хокро
шуста бурдаи об, љои обшустаи дарѓот. 2.
љар, љарї, сой.
ҲББУРЇ بري آب обро бурида гузаштан, шиноварї.
ОБВАРЗ ورز آب обдон, оббоз, шиновар.
ДБВАРЗЇ ورزي آب оббозї, шиноварї.
УБГАЗ آبگز осебдида ва зарардида бар асари
муддати зиёд зери об мондан.
ОБГАРДИШ گردش آب 1. хамгашт (-и дарё). 2.
гирдоб. 3. таѓйири мусбат ва ё манфии таб- дили иќлим ба саломатї; нотобї бар асари
табдили иќлим. 4. кит. тезрафтор, хушраф- тор.';
my $regex = qr/\b([Ѐ-ЯҐ-ҲFӮҶӢ]+)(.+?)(?:\n(?=[Ѐ-ЯҐ-ҲFӮҶӢ])|$)/usp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}