use strict;
my $str = '\'Alice was beginning...to "get" very tired of sitting by her sister on the\'
bank, and of (having) nothing to do: once-or-twice she had peeped into the
book her sister was reading, but --- it had no pictures or conversations in
it, \'and what is the use of a book,\' thought Alice \'without pictures or
conversation?\'
But my banana ate it. Dammit! ugh.';
my $regex = qr/\s+|,|\s-+\s|:|;|\(|\)|(\s+|^)'|'(\s+|$)|^'|"|\.{3}/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";