package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){count=(\d+(?:\.\d+)?), state=(STATE\d+)}`)
var str = `*junk* [{count=240.0, state=STATE1}, {count=1.0, state=STATE2}, {count=93.0, state=STATE3}, {count=1.0, state=STATE4}, {count=1147.0, state=STATE5}, etc. ] *junk*
*junk* [{count=240.0, state=STATE1}, {count=1.0, state=STATE4}, {count=1147.0, state=STATE5}, etc. ] *junk*
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}