re = /{count=(\d+(?:\.\d+)?), state=(STATE\d+)}/m
str = '*junk* [{count=240.0, state=STATE1}, {count=1.0, state=STATE2}, {count=93.0, state=STATE3}, {count=1.0, state=STATE4}, {count=1147.0, state=STATE5}, etc. ] *junk*
*junk* [{count=240.0, state=STATE1}, {count=1.0, state=STATE4}, {count=1147.0, state=STATE5}, etc. ] *junk*
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end