using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((test)(?:.(?!\1))*)$";
string input = @"This is a test to test code";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}