$re = '/((test)(?:.(?!\1))*)$/';
$str = 'This is a test to test code';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);