package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-+]?\d*\.?\d+`)
var str = `abc123d, hello 3.1415926, this is my book`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}