$re = '/[-+]?\d*\.?\d+/';
$str = 'abc123d, hello 3.1415926, this is my book';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);