import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z0-9]{17}).+(?= 2 days)";
final String string = "OUT\n\n"
+ "file CAAYUTIUJIUU00002 reported 78 days\n"
+ "file CAAYUTIUJIUU00004 reported 2 days\n"
+ "file CAAYUTIUJIUU00005 reported 22 days\n"
+ "file CAAYUTIUJIUU00046 reported 2 days";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}