const regex = /([A-Z0-9]{17}).+(?= 2 days)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z0-9]{17}).+(?= 2 days)', 'gm')
const str = `OUT
file CAAYUTIUJIUU00002 reported 78 days
file CAAYUTIUJIUU00004 reported 2 days
file CAAYUTIUJIUU00005 reported 22 days
file CAAYUTIUJIUU00046 reported 2 days`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}