use strict;
my $str = ' align="centered" align="cent\'ered" align=\'cente"red\'';
my $regex = qr/(\S+)=(?'enclosure'[\"\'])?((?:.(?!(?P=enclosure)?\s+(?:\S+)=|\s*\/?(?P=enclosure)))+.)(?P=enclosure)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}