re = /(\S+)=(?'enclosure'[\"\'])?((?:.(?!(?P=enclosure)?\s+(?:\S+)=|\s*\/?(?P=enclosure)))+.)(?P=enclosure)?/m
str = ' align="centered" align="cent\'ered" align=\'cente"red\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end