package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`0{6}\b`)
var str = `70000000
4000000
2000000`
var substitution = "M"
fmt.Println(re.ReplaceAllString(str, substitution))
}