const regex = /0{6}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0{6}\\b', 'g')
const str = `70000000
4000000
2000000`;
const subst = `M`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);