#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\[(?!END).*]$"
Local $sString = "[ITEM1]" & @CRLF & _
"banana" & @CRLF & _
"peach" & @CRLF & _
"apple" & @CRLF & _
"orange" & @CRLF & _
"grapes" & @CRLF & _
"[END]" & @CRLF & _
"[ITEM3]" & @CRLF & _
"tennis" & @CRLF & _
"bowling" & @CRLF & _
"[END]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")