package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(,\s+)|([:])`)
var str = `Hey,This comma will be captured.
hey, this won't be captured.
Hey:this colon will be captured.
Hey: this colon will be captured too.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}