#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(,(?=[\S\n])|:)"
Local $sString = "Hey,This comma will be captured." & @CRLF & _
"hey, this won't be captured." & @CRLF & _
"Hey:this colon will be captured." & @CRLF & _
"Hey: this colon will be captured too." & @CRLF & _
"" & @CRLF & _
"Will this work too," & @CRLF & _
"Yes that one did." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")