$re = '/(,(?=[\S\n])|:)/';
$str = 'Hey,This comma will be captured.
hey, this won\'t be captured.
Hey:this colon will be captured.
Hey: this colon will be captured too.
Will this work too,
Yes that one did.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);