package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\w+/\w+)+)/$`)
var str = `rootURL/
rootURL/abc/
rootURL/abc/123/
rootURL/abc/123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}