re = /^((?:\w+\/\w+)+)\/$/m
str = 'rootURL/
rootURL/abc/
rootURL/abc/123/
rootURL/abc/123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end