$re = '/(?:^|,)\h*+[^\n#@]/m';
$str = '
#yolo
#yolo, #swag
#yolo,@swag
#yolo, @swag,
yolo
swag,#yolo
@swag, yolo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);