re = /(?:^|,)\h*+[^\n#@]/m
str = '
#yolo
#yolo, #swag
#yolo,@swag
#yolo, @swag,
yolo
swag,#yolo
@swag, yolo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end