#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0?[1-9]{1}|[1]{1}[0-7]{1})(\s|[-])?(y(\s?)o|yr([sz]?)|year([sz]?)((\s|[-])?(old)?)|y)((\s?|[-])(old)?)$"
Local $sString = "10y" & @CRLF & _
"10yr" & @CRLF & _
"10yrz" & @CRLF & _
"10yrs" & @CRLF & _
"10 y" & @CRLF & _
"10 yr" & @CRLF & _
"10 yo" & @CRLF & _
"13 y o" & @CRLF & _
"09y" & @CRLF & _
"9y" & @CRLF & _
"09 y" & @CRLF & _
"9yr" & @CRLF & _
"9yo" & @CRLF & _
"9year" & @CRLF & _
"9 years old " & @CRLF & _
"9 yearz old" & @CRLF & _
"17 yo" & @CRLF & _
"17year" & @CRLF & _
"17 years" & @CRLF & _
"17 yearz" & @CRLF & _
"100years" & @CRLF & _
"13" & @CRLF & _
"10 your" & @CRLF & _
"18 yr" & @CRLF & _
"18yr" & @CRLF & _
"10 your" & @CRLF & _
"17-year-old" & @CRLF & _
"17-years-old"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")