package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0?[1-9]{1}|[1]{1}[0-7]{1})(\s|[-])?(y(\s?)o|yr([sz]?)|year([sz]?)((\s|[-])?(old)?)|y)((\s?|[-])(old)?)$`)
var str = `10y
10yr
10yrz
10yrs
10 y
10 yr
10 yo
13 y o
09y
9y
09 y
9yr
9yo
9year
9 years old
9 yearz old
17 yo
17year
17 years
17 yearz
100years
13
10 your
18 yr
18yr
10 your
17-year-old
17-years-old`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}