using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[(?:[^\[\]]*+|(?0))*\])";
string input = @"[DATA1[OTHERDATA]RUBBISH] hello [something]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}