package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[(?:[^\[\]]*+|(?0))*\])`)
var str = `[DATA1[OTHERDATA]RUBBISH] hello [something]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}