package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]+(?: [a-zA-Z0-9]+)*$`)
var str = `good string string
bad string string1
bad string string2
bad string string3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}