#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)BEGIN:VEVENT.*?SUMMARY:(HMIN105M|HMSN118|HMIN121M|HMIN122M).*?END:VEVENT"
Local $sString = "BEGIN:VCALENDAR" & @CRLF & _
"METHOD:PUBLISH" & @CRLF & _
"PRODID:-//ADE/version 6.0" & @CRLF & _
"VERSION:2.0" & @CRLF & _
"CALSCALE:GREGORIAN" & @CRLF & _
"BEGIN:VEVENT" & @CRLF & _
"DTSTAMP:20241023T155849Z" & @CRLF & _
"DTSTART:20241023T111500Z" & @CRLF & _
"DTEND:20241023T124500Z" & @CRLF & _
"SUMMARY:MECA-S1-CM" & @CRLF & _
"LOCATION:B42 - Amphi N (003)" & @CRLF & _
"DESCRIPTION:\\n\\nCM/TD/TP tout Cycle prépa 1\\nAUCHE Doriane\\n\\n(Modifié le" & @CRLF & _
" :31/05/2024 14:00)" & @CRLF & _
"UID:ADE60456d706c6f6973647574656d7073323032342d323032352d36333237302d302d" & @CRLF & _
" 34" & @CRLF & _
"CREATED:19700101T000000Z" & @CRLF & _
"LAST-MODIFIED:20240531T120000Z" & @CRLF & _
"SEQUENCE:2141269420" & @CRLF & _
"END:VEVENT" & @CRLF & _
"BEGIN:VEVENT" & @CRLF & _
"DTSTAMP:20241023T155849Z" & @CRLF & _
"DTSTART:20241025T111500Z" & @CRLF & _
"DTEND:20241025T124500Z" & @CRLF & _
"SUMMARY:TD ATO-S1 GR A" & @CRLF & _
"LOCATION:B41 - 003" & @CRLF & _
"DESCRIPTION:\\n\\nTD GR A Cycle prépa 1\\nCHENU Sebastien\\n\\n(Modifié le:03/" & @CRLF & _
" 06/2024 11:55)" & @CRLF & _
"UID:ADE60456d706c6f6973647574656d7073323032342d323032352d3837332d31312d30" & @CRLF & _
" "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)