import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BEGIN:VEVENT.*?SUMMARY:(HMIN105M|HMSN118|HMIN121M|HMIN122M).*?END:VEVENT";
final String string = "BEGIN:VCALENDAR\n"
+ "METHOD:PUBLISH\n"
+ "PRODID:-//ADE/version 6.0\n"
+ "VERSION:2.0\n"
+ "CALSCALE:GREGORIAN\n"
+ "BEGIN:VEVENT\n"
+ "DTSTAMP:20241023T155849Z\n"
+ "DTSTART:20241023T111500Z\n"
+ "DTEND:20241023T124500Z\n"
+ "SUMMARY:MECA-S1-CM\n"
+ "LOCATION:B42 - Amphi N (003)\n"
+ "DESCRIPTION:\\\\n\\\\nCM/TD/TP tout Cycle prépa 1\\\\nAUCHE Doriane\\\\n\\\\n(Modifié le\n"
+ " :31/05/2024 14:00)\n"
+ "UID:ADE60456d706c6f6973647574656d7073323032342d323032352d36333237302d302d\n"
+ " 34\n"
+ "CREATED:19700101T000000Z\n"
+ "LAST-MODIFIED:20240531T120000Z\n"
+ "SEQUENCE:2141269420\n"
+ "END:VEVENT\n"
+ "BEGIN:VEVENT\n"
+ "DTSTAMP:20241023T155849Z\n"
+ "DTSTART:20241025T111500Z\n"
+ "DTEND:20241025T124500Z\n"
+ "SUMMARY:TD ATO-S1 GR A\n"
+ "LOCATION:B41 - 003\n"
+ "DESCRIPTION:\\\\n\\\\nTD GR A Cycle prépa 1\\\\nCHENU Sebastien\\\\n\\\\n(Modifié le:03/\n"
+ " 06/2024 11:55)\n"
+ "UID:ADE60456d706c6f6973647574656d7073323032342d323032352d3837332d31312d30\n"
+ " ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}