package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\?\s*((?:.*\/\*[\s\S]+\*\/.*)|(?:[\s\S]+?))\s*\?>`)
var str = `<? /* hello */ ?>
html
<? /* world*/ ?>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}