re = /<\?\s*((?:.*\/\*[\s\S]+\*\/.*)|(?:[\s\S]+?))\s*\?>/
str = '<? /* hello */ ?>
html
<? /* world*/ ?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end