# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*age:\s*(\d+)\s*\) I live in (.+)\./$1, $2/gm;t' <<< "Hello my name is Adam (age: 25) I live in US.
Hello my name is Bill (age: 23) I live in Asia.
Hello my name is Alice (age: 26) I live in some other country."