$re = '/.*age:\s*(\d+)\s*\) I live in (.+)\./m';
$str = 'Hello my name is Adam (age: 25) I live in US.
Hello my name is Bill (age: 23) I live in Asia.
Hello my name is Alice (age: 26) I live in some other country.';
$subst = "$1, $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;