re = /\b(?=[a-zA-Z_%-]*[0-9])[a-zA-Z0-9_%-]{5,}/m
str = '/someService/US/getPersonFromAllAccessoriesByDescription/67814/alloy%20nudge%20w
/someService/NZ/asdNmasdf423-asd342e/getDealerFromSomethingSomething/FS443GH/front%20parking%20sen'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end