using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Total pris: (?<total_pris>[\d.,]+)\sNr: (?<nr>\d+)";
string input = @"Total pris: 2.125,01
Nr: 1589";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}