const regex = /Total pris: (?<total_pris>[\d.,]+)\sNr: (?<nr>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Total pris: (?<total_pris>[\\d.,]+)\\sNr: (?<nr>\\d+)', 'gm')
const str = `Total pris: 2.125,01
Nr: 1589`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}