re = /(DCG_.*?)<\/div>/m
str = '<div data-wrapper="true" style="font-size:9pt;font-family:\'Segoe UI\',\'Helvetica Neue\',sans-serif;"><div>DCG_QLKNDFALGKFNDGOIQERKNGLÑADKFNGOWQIREG</div></div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end