$re = '/([“])+|([”])+/';
$str = '“Ba“Bayern”yern”';
$subst = "\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;