package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)=(.+?);`)
var str = `gene_name=TRBV3-1-201;gene=nskn;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}