$re = '/=(.+?);/m';
$str = 'gene_name=TRBV3-1-201;gene=nskn;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);