#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\*[^*]*\*+([^\/*][^*]*\*+)*\/" & @CRLF & _
""
Local $sString = "/* = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = */" & @CRLF & _
"" & @CRLF & _
"/* @TODO:" & @CRLF & _
" - Notes..." & @CRLF & _
"*/" & @CRLF & _
" " & @CRLF & _
"/* = = = Set Base Font Size = = = So 1em = 10px / 1.8em = 18px etc */" & @CRLF & _
"body { font-size: 62.5% }" & @CRLF & _
"" & @CRLF & _
"body, ul, li {" & @CRLF & _
" color: #333333;" & @CRLF & _
" font-family: 'Open Sans', verdana, arial, helvetica, helve, sans-serif;" & @CRLF & _
" font-weight: 400;" & @CRLF & _
"/* font-size: 1.4em; Default font = 14px normal weight Open Sans using #333333 */" & @CRLF & _
" line-height: 1.25em;" & @CRLF & _
"}" & @CRLF & _
"body {" & @CRLF & _
" margin: 0; /* Nav bar and footer need to fit edge to edge so no margins! */" & @CRLF & _
" padding: 0;" & @CRLF & _
" top: 0;" & @CRLF & _
" border-bottom: 1px #1C1C1C solid; /* To remove white space under the popup footer */" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/* = = = Typography = = = */" & @CRLF & _
"/* Font choice was carefully considered, Open Sans is very popular so many visitors will already have it cached. */" & @CRLF & _
"/* Monda & Shadows into light are also quite popular so may be cached too */" & @CRLF & _
"/* = = = Headings = = = */" & @CRLF & _
"h1, h2, h3, h4, h5, h6 {" & @CRLF & _
" font-family: 'Monda', 'Trebuchet MS', verdana, arial, helvetica, helve, sans-serif;" & @CRLF & _
" font-weight: 400;" & @CRLF & _
" line-height: 1.2em;" & @CRLF & _
" letter-spacing: 1px;" & @CRLF & _
" color: #333333;" & @CRLF & _
" margin-top: 10px;" & @CRLF & _
" margin-bottom: 20px;" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")