# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"\/\*[^*]*\*+([^\/*][^*]*\*+)*\/\n")
test_str = ("/* = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = */\n\n"
"/* @TODO:\n"
" - Notes...\n"
"*/\n"
" \n"
"/* = = = Set Base Font Size = = = So 1em = 10px / 1.8em = 18px etc */\n"
"body { font-size: 62.5% }\n\n"
"body, ul, li {\n"
" color: #333333;\n"
" font-family: 'Open Sans', verdana, arial, helvetica, helve, sans-serif;\n"
" font-weight: 400;\n"
"/* font-size: 1.4em; Default font = 14px normal weight Open Sans using #333333 */\n"
" line-height: 1.25em;\n"
"}\n"
"body {\n"
" margin: 0; /* Nav bar and footer need to fit edge to edge so no margins! */\n"
" padding: 0;\n"
" top: 0;\n"
" border-bottom: 1px #1C1C1C solid; /* To remove white space under the popup footer */\n"
"}\n\n\n"
"/* = = = Typography = = = */\n"
"/* Font choice was carefully considered, Open Sans is very popular so many visitors will already have it cached. */\n"
"/* Monda & Shadows into light are also quite popular so may be cached too */\n"
"/* = = = Headings = = = */\n"
"h1, h2, h3, h4, h5, h6 {\n"
" font-family: 'Monda', 'Trebuchet MS', verdana, arial, helvetica, helve, sans-serif;\n"
" font-weight: 400;\n"
" line-height: 1.2em;\n"
" letter-spacing: 1px;\n"
" color: #333333;\n"
" margin-top: 10px;\n"
" margin-bottom: 20px;\n"
"}\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.