$re = '/(?<=\@{)[A-Za-z\.]*(?=})/';
$str = 'This is my template @{test.html} bla bla bla @{test.html}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);