re = /(?<=\@{)[A-Za-z\.]*(?=})/
str = 'This is my template @{test.html} bla bla bla @{test.html}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end