package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)^aaa$(.*?)^bbb$`)
var str = `aaa
test
test
test
test
bbb
aaa
test
test
bbb
aaa
test
test
test
test
test
test
bbb
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}